S2S submissions failure rate increased

Incident Report for BOMcheck

Resolved

Issue has been identified and fix has been released.
Posted Mar 09, 2021 - 07:13 UTC

Investigating

We are currently investigating this issue.
Posted Mar 09, 2021 - 07:00 UTC